Back to overview
Degraded

API and Web instability

May 07 at 02:45am HDT
Affected services
Euler Platform & Landing Page
Euler API

Resolved
May 10 at 05:53am HDT

The issue was caused by a service disruption with a third party hosting provider. It has since been solved.

Created
May 07 at 02:45am HDT

We’re currently investigating an issue causing high latency for a small number of API requests. Our team is actively working on a fix, and performance will return to normal shortly. Thanks for your patience.